ACM

E-超级楼梯

简单例题

Posted by lvvyonghao on December 19, 2018

E - 超级楼梯

有一楼梯共M级,刚开始时你在第一级,若每次只能跨上一级或二级,要走上第M级,共有多少种走法?

Input

输入数据首先包含一个整数N,表示测试实例的个数,然后是N行数据,每行包含一个整数M(1<=M<=40),表示楼梯的级数。

Output

对于每个测试实例,请输出不同走法的数量

Sample Input

2 2 3

Sample Output

1 2

#include<cstdio>  
#include<algorithm>  
using namespace std;  
  
int main()  
{  
    int n;  
    int a[45];  
    a[1]=1;  
    a[2]=1;  
    a[3]=2;  
    for(int i=4;i<=40;i++)  
        a[i]=a[i-1]+a[i-2];  
    scanf("%d",&n);  
    while(n--){  
        int m;  
        scanf("%d",&m);  
        printf("%d\n",a[m]);  
    }  
      
    return 0;  
}